United States
GSM
HSDPA

FreedomPop APN settings for Alcatel Pop D5

      FreedomPop   Alcatel Pop D5   Android

Alcatel Pop D5 does not support FreedomPop GSM / HSPA at this time.

Explain Alcatel Pop D5 compatibility with FreedomPop

FreedomPop CDMA with Alcatel Pop D5

Alcatel Pop D5 does not support FreedomPop CDMA.

Sorry, but it does not look like Alcatel Pop D5 will work on FreedomPop. But please note that the compatibility of Alcatel Pop D5 with FreedomPop, or the FreedomPop network support on Alcatel Pop D5 we have explained here is only a technical specification match between Alcatel Pop D5 and FreedomPop network. Even Alcatel Pop D5 is listed as not compatible here, still FreedomPop network can allow (rarely) Alcatel Pop D5 in their network with special agreements made between FreedomPop and Alcatel. Therefore, this only explains if the commonly available versions of Alcatel Pop D5 will work properly on FreedomPop or not, if so in which bands Alcatel Pop D5 will work on FreedomPop and the network performance between FreedomPop and Alcatel Pop D5. To check if Alcatel Pop D5 is really allowed in FreedomPop network please contact FreedomPop support. Do not use this website to decide to buy Alcatel Pop D5 to use on FreedomPop.

Alcatel Pop D5 network specifications

OS Android OS, v4.4.2 (KitKat)
Network bands GSM / HSPA
Speed HSPA 21.1/5.76 Mbps
Network frequencies GSM 850 / 900 / 1800 / 1900
HSDPA 900 / 2100

See full specs at GSM.COOL... Select a different device... Select a different network...
Alcatel Pop D1 FreedomPop APN settings
Not compatible
Alcatel Pop D3 FreedomPop APN settings
Not compatible
Alcatel POP 10 FreedomPop APN settings
Not compatible
alcatel Pop 4S FreedomPop APN settings
Not compatible
Alcatel POP 8S FreedomPop APN settings
Not compatible
Alcatel Pop C1 FreedomPop APN settings
Not compatible
Alcatel Pop C2 FreedomPop APN settings
Not compatible
Alcatel Pop C3 FreedomPop APN settings
Not compatible
Alcatel Pop C7 FreedomPop APN settings
Not compatible
Alcatel Pop C9 FreedomPop APN settings
Not compatible