United States
GSM
HSDPA
LTE

FreedomPop APN settings for LG Q60

      FreedomPop   LG Q60   Android

LG Q60 does not support FreedomPop GSM / HSPA / LTE at this time.

Explain LG Q60 compatibility with FreedomPop

FreedomPop CDMA with LG Q60

LG Q60 does not support FreedomPop CDMA.

FreedomPop 4G LTE APN with LG Q60

LG Q60 does not support FreedomPop 4G LTE.

Sorry, but it does not look like LG Q60 will work on FreedomPop. But please note that the compatibility of LG Q60 with FreedomPop, or the FreedomPop network support on LG Q60 we have explained here is only a technical specification match between LG Q60 and FreedomPop network. Even LG Q60 is listed as not compatible here, still FreedomPop network can allow (rarely) LG Q60 in their network with special agreements made between FreedomPop and LG. Therefore, this only explains if the commonly available versions of LG Q60 will work properly on FreedomPop or not, if so in which bands LG Q60 will work on FreedomPop and the network performance between FreedomPop and LG Q60. To check if LG Q60 is really allowed in FreedomPop network please contact FreedomPop support. Do not use this website to decide to buy LG Q60 to use on FreedomPop.

LG Q60 network specifications

OS Android 9.0 (Pie)
Network bands GSM / HSPA / LTE
Speed HSPA, LTE-A
Network frequencies GSM 850 / 900 / 1800 / 1900 - SIM 1 & SIM 2 (dual-SIM model only)
HSDPA 850 / 900 / 1900 / 2100
LTE band 1(2100), 3(1800), 7(2600), 8(900), 20(800), 38(2600)
See full specs at GSM.COOL... Select a different device... Select a different network...
LG Q6 FreedomPop APN settings
25% compatible with FreedomPop
LTE
LG Q7 FreedomPop APN settings
25% compatible with FreedomPop
LTE
LG Q9 FreedomPop APN settings
Not compatible
LG Q70 FreedomPop APN settings
Not compatible
LG AKA FreedomPop APN settings
Not compatible
LG Joy FreedomPop APN settings
Not compatible
LG K10 FreedomPop APN settings
Not compatible
LG K30 FreedomPop APN settings
Not compatible
LG K40 FreedomPop APN settings
Not compatible
LG K50 FreedomPop APN settings
Not compatible