United States
GSM
HSDPA

TruConnect APN settings for Alcatel Pop D5

      TruConnect   Alcatel Pop D5   Android

Alcatel Pop D5 does not support TruConnect GSM / HSPA at this time.

Explain Alcatel Pop D5 compatibility with TruConnect

TruConnect CDMA with Alcatel Pop D5

Alcatel Pop D5 does not support TruConnect CDMA.

Sorry, but it does not look like Alcatel Pop D5 will work on TruConnect. But please note that the compatibility of Alcatel Pop D5 with TruConnect, or the TruConnect network support on Alcatel Pop D5 we have explained here is only a technical specification match between Alcatel Pop D5 and TruConnect network. Even Alcatel Pop D5 is listed as not compatible here, still TruConnect network can allow (rarely) Alcatel Pop D5 in their network with special agreements made between TruConnect and Alcatel. Therefore, this only explains if the commonly available versions of Alcatel Pop D5 will work properly on TruConnect or not, if so in which bands Alcatel Pop D5 will work on TruConnect and the network performance between TruConnect and Alcatel Pop D5. To check if Alcatel Pop D5 is really allowed in TruConnect network please contact TruConnect support. Do not use this website to decide to buy Alcatel Pop D5 to use on TruConnect.

Alcatel Pop D5 network specifications

OS Android OS, v4.4.2 (KitKat)
Network bands GSM / HSPA
Speed HSPA 21.1/5.76 Mbps
Network frequencies GSM 850 / 900 / 1800 / 1900
HSDPA 900 / 2100

See full specs at GSM.COOL... Select a different device... Select a different network...
Alcatel Pop D1 TruConnect APN settings
Not compatible
Alcatel Pop D3 TruConnect APN settings
Not compatible
Alcatel POP 10 TruConnect APN settings
Not compatible
alcatel Pop 4S TruConnect APN settings
Not compatible
Alcatel POP 8S TruConnect APN settings
Not compatible
Alcatel Pop C1 TruConnect APN settings
Not compatible
Alcatel Pop C2 TruConnect APN settings
Not compatible
Alcatel Pop C3 TruConnect APN settings
Not compatible
Alcatel Pop C7 TruConnect APN settings
Not compatible
Alcatel Pop C9 TruConnect APN settings
Not compatible